OSPF 多区域布局

H3CSE路由-配置OSPF高级,h3cse路由ospf

PS:本篇仅挑选作者认为重要的模块,并不全面仅供复习参考,具体请自行查阅相关书籍。设有H3CNE-H3CTE学习博客专栏,敬请关注。

一条虚连接只能穿越一个区域

OSPF邻居之间交互的是链路信息(LSA)

LSA是携带在LSU(更新消息)中

LSA格式

     LSA报文头+LSA PDU(携带具体的链路描述信息)

根据Link state ID和LS sequence number判断LSA谁新谁旧

Type 1 LSA (Router LSA)

    描述设备的直连链路(和直连链路相连的接口必须使能OSPF)

任何OSPF设备都会产生1类LSA

1类LSA不能跨区域传递

Type 2 LSA(Network LSA)

描述广播型网或NBMA网的结构

只能由DR产生

2类LSA不能跨区域传递

Type 3 LSA(Network Summary LSA)

由ABR产生

      ABR会阻止某个区域的1类和2类LSA进入其他区域,根据这些1和2类LSA生成的路由信息以3类LSA的形式宣告进其他区域!!!

      3类LSA可以跨区域

Type 4 LSA(ASBR summary LSA)

ABR产生,描述ASBR的router
id,可以跨区域传递(告诉其他人谁是ASBR)

Type 5 LSA(AS external LSA)

ASBR产生,描述被引入的外部路由,可以跨区域传递

Display ospf lsdb

     列出数据库中每条lsa的报文头

Display ospf lsdb 类型 link-id

Ex:display ospf lsdb router 3.3.3.3

1和2类LSA生成区域内OSPF路由———————O_Intra

3类LSA生成区域间路由———————————-O_Inter

5类LSA生成AS外部路由———————————-O_ASE

OSPF附录E解决ASBR所连接的同网段不同掩码的网络的引入。

合理的减少需要传递的LSA类型和数目

(1)协议默认路由
default-route-adavertise

(2)特殊区域

(3)ospf聚合

特殊区域:

1.stub.     末梢区域

2.totally stub

3.nssa  not so stub area 

4.totally nssa

Stub区域:

       连接到末梢区域的abr会阻止 4和5类lsa进入末梢区域,同时该abr会自动向末梢区域内宣告默认路由(3类LSA)

1.末梢区域内不允许存在ASBR

2.area 0 绝对不能被定义为特殊区域

3.虚连接不能穿过特殊区域

#ospf X

      Area X

         Stub

特殊区域内的所有设备都要配置,包括ABR,否则邻居无法建立

Totally stub:

在stub的基础上,还阻止3类LSA。自动向完全末梢区域宣告默认路由。

 

两种配置都行

Area 2和area 0会认为abr_2是asbr路由器

 

nssa区域发布默认路由(nssa区域不能自动生成,而stub区域和totally
stub区域回自动发布):Nssa default-route-advertise

区域间聚合 Abr-summary

AS外部路由聚合 asbr-summary

   区域间聚合:

       1.必须在abr设备上配置

       2.对某个区域的区域内子网路由聚合

       3.支持超网聚合

       4.ABR聚合成功后,ABR的IP路由表中自动生成黑洞路由防环

AS外部路由聚合:

   1.必须配置在ASBR设备上

   2.对被引入OSPF的外部子网路由聚合

   3.支持超网聚合

   4.聚合成功后,ASBR的ip路由表中自动生成黑洞路由防环

Ospf X

     Import-route X

     Asbr-summary X.X.X.X y

OSPF协议认证:

    验证收到的OSPF消息是否合法,不合法的丢弃

1.区域验证:区域为范围

2.接口验证:邻居为范围

接口认证:邻居之间的认证,其他邻居可以不用开启

区域认证:该区域的所有设备都要开启

Ospf authentication-mode

把使能了OSPF且连接到用户网段的接口定义为OSPF的静默口

#ospf x

  Silence-interface端口号

  只收不发协议消息

查看评论

PS:
本篇仅挑选作者认为重要的模块,并不全面仅供复习参考,具体请自行查阅相关书籍。设有H3CNE-H…

安徽工业经济职业技术学院  31715  422

1、配置三台路由器IP
R1(config)#INTER S1/0
R1(config-if)#IP ADDress 192.1.12.1 255.255.255.0
R1(config-if)#no shut

安徽工业经济职业技术学院    17#422

安徽工业经济职业技术学院 – 31715 – 17#301


R1(config)#inter lo 1
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#no shut

实验目的:


实验目的:

(注意:IP OSPF NETWORK POINT-TO-POINT 意思是不要指定1.1.1.1为32位)

(1)实现全网互通

一、实验目的

  • 实现全网的互通
  • 通过更改优先级,实现不同路由之间的转换
  • 练习OSPF 多区域/单区域配置和管理方法

图片 1

实验拓扑图

  1. 实现全网的互通。

  2. 通过更改优先级来实现不同路由的转化。

R1(config-if)#inter s1/1
R1(config-if)#ip address 192.1.13.1 255.255.255.0
R1(config-if)#no shut

(2)通过操作,实现不同路由之间的转换

二、 实验步骤

实验要点:

R2(config)#inter s1/0
R2(config-if)#ip address 192.1.12.2 255.255.255.0
R2(config-if)#no shut

(3)练习OSPF多区域/单区域的配置和管理方法

1. 配置PC机、路由器、服务器的IP地址

 - Router0
Router>enable
Router0#configure terminal
Router0(config)#interface FastEthernet0/0
Router0(config-if)#ip address 10.0.0.254 255.255.255.0
Router0(config-if)#no shutdown
Router0(config-if)#exit
Router0(config)#interface FastEthernet0/1
Router0(config-if)#ip address 20.0.0.254 255.255.255.0
Router0(config-if)#no shutdown
Router0(config-if)#exit
Router0(config)#interface Serial1/0
Router0(config-if)#clock rate 64000
Router0(config-if)#ip address 30.0.0.1 255.255.255.0
Router0(config-if)#no shutdown
Router0(config-if)#exit

 - Router1
Router>enable
Router1#configure terminal
Router1(config)#interface FastEthernet0/0
Router1(config-if)#ip address 60.0.0.254 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#interface Serial1/0
Router1(config-if)#clock rate 64000
Router1(config-if)#ip address 30.0.0.2 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#exit
Router1(config)#interface Serial1/1
Router1(config-if)#clock rate 64000
Router1(config-if)#ip address 40.0.0.1 255.255.255.0
Router1(config-if)#no shutdown

 - Router2
Router>enable
Router2#configure terminal
Router2(config)#interface Serial1/0
Router0(config-if)#clock rate 64000
Router2(config-if)#ip address 40.0.0.2 255.255.255.0
Router2(config-if)#no shutdown
Router2(config-if)#exit
Router2(config)#interface FastEthernet0/0
Router2(config-if)#ip address 50.0.0.254 255.255.255.0
Router2(config-if)#no shutdown
  1. OSPF 多区域的划分。

  2. OSPF 路由条目。

R2(config-if)#inter lo 1
R2(config-if)#ip address 2.2.2.2 255.255.255.0
R2(config-if)#ip ospf network point-to-point 
//不让它认为这是一条主机路由

实验拓扑图:

2. 开启OSPF并设置区域公布网路

 - Router0
Router0(config)#router ospf 100
Router0(config-router)#network 10.0.0.0 0.0.0.255 area 1
Router0(config-router)#network 20.0.0.0 0.0.0.255 area 1
Router0(config-router)#network 30.0.0.0 0.0.0.255 area 1

 - Router1
Router1(config)#interface  Serial1/0
Router1(config-if)#clock rate 64000
Router1(config-if)#extit
Router1(config)#interface serial1/1
Router1(config-if)#clock rate 64000
Router1(config-if)#exit
Router1(config)#router ospf 200
Router1(config-router)#network60.0.0.0 0.0.0.255 area 2
Router1(config-router)#network30.0.0.0 0.0.0.255 area 1
Router1(config-router)#network 40.0.0.0 0.0.0.255 area3
Router1(config-router)#network 50.0.0.0 0.0.0.255 area3
Router2(config-router)#network 10.0.0.0 0.0.0.255 area 1
Router2(config-router)#network 20.0.0.0 0.0.0.255 area 1

 - Router2
Router2(config)#interface serial0/0
Router2(config-if)#clock rate 64000
Router2(config-if)#extit
Router2(config)#interface serial1/1
Router2(config-if)#clock rate 64000
Router2(config-if)#exit
Router2(config)#router ospf 300
Router2(config-router)#network 40.0.0.0 0.0.0.255 area 3
Router2(config-router)#network 50.0.0.0 0.0.0.255 area 3
Router2(config-router)#end
Router2#show ip route

实验拓扑图:

R3(config)#inter s1/1
R3(config-if)#ip address 192.1.13.3 255.255.255.0
R3(config-if)#no shut

图片 2

三、总结

OSPF路由协议支持两级分层结构。利用单区域或多区域OSPF设计,不仅提高网络稳定性,还能减少路由器上的负载和使用率。通过介绍单区域和多区域OSPF设计之间的差异来规划OSPF的实施。

图片 3

R3(config-if)#inter lo 1
R3(config-if)#ip address 3.3.3.3 255.255.255.0
R3(config-if)#ip ospf network point-to-poin
完成配置后在R1上测试两边的连通性

实验拓扑图

实验拓扑图

2、启用OSPF协议
R1(config)#router ospf ?
  <1-65535>  Process ID
R1(config)#router ospf 100
手工指定ROUTE-ID
R1(config-router)#router-id 1.1.1.1
指定区域

实验步骤

实验名称:OSPF的配置

R1(config-router)#network 192.1.12.0 0.0.0.255 ?
  area  Set the OSPF area ID
R1(config-router)#network 192.1.12.0 0.0.0.255 a 0
R1(config-router)#network 192.1.13.0 0.0.0.255 a 0
R1(config-router)#network 1.1.1.1 0.0.0.0 a 0

(1) 配置PC机.路由器.服务器的IP地址

实验目的:

R2(config)#router ospf 100   //可以不一制
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 192.1.12.0 0.0.0.255 a 0
R2(config-router)#network 2.2.2.0 0.0.0.255 a 1

R0

  1. 实现全网的互通。

  2. 通过更改优先级来实现不同路由的转化。

R3(config)#router ospf 100
R3(config-router)#router-id 3.3.3.
R3(config-router)#network 192.1.13.0 0.0.0.255 a 0
R3(config-router)#network 3.3.3.0 0.0.0.255 a 2

R0>enable

实验要点:

3、查看邻居关系
R1#show ip ospf neighbor
4、查看路由表
R1#show ip route

R0#configure terminal.

  1. OSPF 多区域的划分。

  2. OSPF 路由条目。

5、在R1上PING下区域1的环回地址(2.2.2.2),可以通
PING区域2(3.3.3.3),也可以通
6、可以查看数据库
R1#show ip ospf database
7、几个OSPF常用命令
R1#show ip ospf ?
show ip ospf border-routers (查看路由器的角色等)
R1#show ip ospf(查看基本信息,比如进程号)
R1#show ip protocols(查看运行的协议)

R0(config)#interface FastEthernet0/0

实验拓扑图:

R0(config-if)#ip address 10.0.1.254 255.255.255.0

实验步骤:

R0(config-if)#no shutdown

R1:

R0(config-if)#exit

Router(config)#hostname R1

R0(config)#interface FastEthernet0/1

R1(config)#interface f0/1

R0(config-if)#ip address 10.0.2.254 255.255.255.0

R1(config)#clock rate 64000

R0(config-if)#no shutdown

R1(config-if)#ip address 10.0.1.254 255.255.255.0

R0(config-if)#exit

R1(config-if)#no shutdown

R0(config)#interface Serial1/0

R2:

R0(config-if)#ip address 30.0.0.1 255.255.255.0

R2(config)#interface s1/1

R0(config-if)#clock rate 64000

R2(config)#clock rate 64000

R0(config-if)#no shutdown

R2(config-if)#ip address 30.0.0.2 255.255.255.0

R1

R2(config-if)#no shutdown

R1>enable

R3:

R1#configure terminal

R3(config)#interface f0/0

R1(config)#interface FastEthernet0/0

R3(config-if)#ip address 50.0.0.254 255.255.255.0

R1(config-if)#ip address 20.0.0.254 255.255.255.0

R3(config-if)#no shutdown

R1(config-if)#no shutdown

R1

R1(config-if)#exit

R1(config)#router ospf

R1(config)#interface Serial1/0

R1(config-router)#network 10.0.1.0 0.0.0.255 area 1

R1(config-if)#ip address 40.0.0.1 255.255.255.0

R1(config-router)#network 10.0.2.0 0.0.0.255 area 1

R1(config-if)#clock rate 64000

R1(config-router)#network 30.0.0.0 0.0.0.255 area 1

R1(config-if)#no shutdown

R2:

R1(config-if)#exit

R1(config-router)#network 10.0.1.0 0.0.0.255 area 1

R1(config)#interface Serial1/1

R1(config-router)#network 10.0.2.0 0.0.0.255 area 1

R1(config-if)#ip address 30.0.0.2 255.255.255.0

R2(config-router)#network 30.0.0.0 0.0.0.255 area 1

R1(config-if)#clock rate 64000

R2(config-router)#network 20.0.0.0 0.0.0.255 area 2

R1(config-if)#no shutdown

R2(config-router)#network 40.0.0.0 0.0.0.255 area 3

R2

R2(config-router)#network 50.0.0.0 0.0.0.255 area 3

R2>enable

R3:

R2#configure terminal

R3(config-router)#network 40.0.0.0 0.0.0.255 area 3

R2(config)#interface FastEthernet0/0

R3(config-router)#network 50.0.0.0 0.0.0.255 area 3

R2(config-if)#ip address 50.0.0.254 255.255.255.0

R3(config-router)#exit

R2(config-if)#no shutdown

R3#show ip route

R2(config-if)#exit

个人总结:

R2(config)#interface Serial1/1

  1. 首先ospf进程号两边要相同;

R2(config-if)#ip address 40.0.0.2 255.255.255.0

实验名称:OSPF的配置

R2(config-if)#clock rate 64000

实验目的:

R2(config-if)#no shutdown

  1. 实现全网的互通。

  2. 通过更改优先级来实现不同路由的转化。

(2) OPSF的开启和设置区域公布网络

实验要点:

R0

  1. OSPF 多区域的划分。

  2. OSPF 路由条目。

R0>enable

实验拓扑图:

R0#configure terminal

实验步骤:

R0(config)#router ospf 12200

R1:

R0(config-router)#net 10.0.1.0 0.0.0.255 area 1

Router(config)#hostname R1

R0(config-router)#net 10.0.2.0 0.0.0.255 area 1

R1(config)#interface f0/1

R0(config-router)#net 30.0.0.0 0.0.0.255 area 1

R1(config)#clock rate 64000

R1

R1(config-if)#ip address 10.0.1.254 255.255.255.0

R1>enable

R1(config-if)#no shutdown

R1#configure terminal

R2:

R1(config)#router ospf 12200

R2(config)#interface s1/1

R1(config-router)#net 30.0.0.0 0.0.0.255 area 1

R2(config)#clock rate 64000

R1(config-router)#net 20.0.0.0 0.0.0.255 area 0

R2(config-if)#ip address 30.0.0.2 255.255.255.0

R1(config-router)#net 40.0.0.0 0.0.0.255 area 2

R2(config-if)#no shutdown

R2

R3:

R2>enable

R3(config)#interface f0/0

R2#configure terminal

R3(config-if)#ip address 50.0.0.254 255.255.255.0

R2(config)#router ospf 12200

R3(config-if)#no shutdown

R2(config-router)#net 40.0.0.0 0.0.0.255 area 2

R1

R2(config-router)#net 50.0.0.0 0.0.0.255 area 2

R1(config)#router ospf

实验结果:

R1(config-router)#network 10.0.1.0 0.0.0.255 area 1

PC>ping 50.0.0.1

R1(config-router)#network 10.0.2.0 0.0.0.255 area 1

Pinging 50.0.0.1 with 32 bytes of data:

R1(config-router)#network 30.0.0.0 0.0.0.255 area 1

Reply from 50.0.0.1: bytes=32 time=9ms TTL=125

R2:

Reply from 50.0.0.1: bytes=32 time=2ms TTL=125

R1(config-router)#network 10.0.1.0 0.0.0.255 area 1

Reply from 50.0.0.1: bytes=32 time=10ms TTL=125

R1(config-router)#network 10.0.2.0 0.0.0.255 area 1

Reply from 50.0.0.1: bytes=32 time=2ms TTL=125

R2(config-router)#network 30.0.0.0 0.0.0.255 area 1

Ping statistics for 50.0.0.1:

R2(config-router)#network 20.0.0.0 0.0.0.255 area 2

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

R2(config-router)#network 40.0.0.0 0.0.0.255 area 3

Approximate round trip times in milli-seconds:

R2(config-router)#network 50.0.0.0 0.0.0.255 area 3

Minimum = 2ms, Maximum = 10ms, Average = 5ms

R3:

设置OSPF协议有以下优点

R3(config-router)#network 40.0.0.0 0.0.0.255 area 3

(1) 可实现全网通的通信同时可通过更改优先级以及开销值更改路由路径

R3(config-router)#network 50.0.0.0 0.0.0.255 area 3

(2) 避免骨干区域压力过大 形成负载分担

R3(config-router)#exit

(3) 每个网络有自己的区域降低了域内每个路由器的压力

R3#show ip route

个人总结:

  1. 首先ospf进程号两边要相同;

  2. 两边接口的地址要在同一网段;

  3. 宣告网段时要注意带反掩码进行匹配,后面跟上区域号;

实验步骤:

R1:

Router(config)#hostname R1

R1(config)#interface f0/1

R1(config)#clock rate 64000

R1(config-if)#ip address 10.0.1.254 255.255.255.0

R1(config-if)#no shutdown

R2:

R2(config)#interface s1/1

R2(config)#clock rate 64000

R2(config-if)#ip address 30.0.0.2 255.255.255.0

R2(config-if)#no shutdown

R3:

R3(config)#interface f0/0

R3(config-if)#ip address 50.0.0.254 255.255.255.0

R3(config-if)#no shutdown

R1

R1(config)#router ospf

R1(config-router)#network 10.0.1.0 0.0.0.255 area 1

R1(config-router)#network 10.0.2.0 0.0.0.255 area 1

R1(config-router)#network 30.0.0.0 0.0.0.255 area 1

R2:

R1(config-router)#network 10.0.1.0 0.0.0.255 area 1

R1(config-router)#network 10.0.2.0 0.0.0.255 area 1

R2(config-router)#network 30.0.0.0 0.0.0.255 area 1

R2(config-router)#network 20.0.0.0 0.0.0.255 area 2

R2(config-router)#network 40.0.0.0 0.0.0.255 area 3

R2(config-router)#network 50.0.0.0 0.0.0.255 area 3

R3:

R3(config-router)#network 40.0.0.0 0.0.0.255 area 3

R3(config-router)#network 50.0.0.0 0.0.0.255 area 3

R3(config-router)#exit

R3#show ip route

个人总结:

  1. 首先ospf进程号两边要相同;

  2. 两边接口的地址要在同一网段;

  3. 宣告网段时要注意带反掩码进行匹配,后面跟上区域号

相关文章